Support Articles — Bug

“Specified Cast Not Valid” Error in MadgeTech 4

Posted on

A recent Windows 10 update triggered a bug in the MadgeTech 4 software that may cause the program to crash when starting loggers.

This issue has been fixed in recent software versions. For users of the free version of MadgeTech 4, updating to the latest version will resolve this issue. The most recent version of MadgeTech 4 can be downloaded here: https://www.madgetech.com/software/madgetech-4-software/

There is an alternative fix that will allow MadgeTech 4 Secure users to continue using their existing software version without experiencing this crash. Follow these steps to prevent the crash:

Continue reading “Specified Cast Not Valid” Error in MadgeTech 4
Sign up for the MadgeTech Blog
Subscribe to our blog