Support Articles

HiTemp140 – Incompatible or “Not Supported” by Current Software Version

Posted on

All new and repaired HiTemp140 series loggers received after May 2018 have improved firmware that requires Standard software version 4.2.13.1 or Secure software version 4.2.12.1 or later.

To check the current version of software, open the Madgetech 4 software and go to: File >> Options >> About

To update Madgetech 4 Standard software, go to:  http://www.madgetech.com/software-download

To purchase the MadgeTech 4 Secure software upgrade, please contact:  [email protected] 

About Thomas King:

Sign up for the MadgeTech Blog
Subscribe to our blog