Made in the USA

Skip to Main Content »

Knowledge Base

THIS ARTICLE DOES NOT APPLY TO WINDOWS 10 USERS

If the software will not open, this may be due to an issue with the specific version of the Microsoft .NET framework on the user's PC.

When Microsoft released .NET framework 4.5, it had a bug that prevented a lot of software packages—including ours—from running properly.  They have since released 4.5.1 and 4.5.2, both of which work fine with our software.

Go to Control Panel in your Start Menu and select Programs and Features.  Scroll down to the listing for Microsoft .NET Framework and check the full name and the specific version number.  If the installed version is Microsoft .NET Framework 4.5 (actual version in the right-hand column may say 4.5.50709) rather than 4.5.1 or 4.5.2, then that is likely the issue.  Note, the new 4.6.1 version included with Windows 10 should be fine as well.

Microsoft has since patched this version to 4.5.1/4.5.2 as they inadvertently affected many small software companies like us.  .NET 4.5 changed a registry function that doesn’t work with our software or many other packages.

Linked you will find a download page from Microsoft for 4.5.2, please download and install this new .NET framework, restart your computer, and then try running the software again.  http://www.microsoft.com/en-us/download/details.aspx?id=42643

If this does not solve the problem, please review the article "MadgeTech 4 will not open - DbProviderFactories error".

Rating: